Вопрос по информатике:
1)напишите программу,которая спрашивает целое число n и считает сумму целых чисел ,сумму чётных чисел и сумму нечётных от 1 до n
2)напишите программу, которая спрашивает целые числа а и b и выводит на экран квадраты чисел от а до b
(Паскаль)
- 15.08.2015 09:11
- Информатика
- remove_red_eye 1256
- thumb_up 18
Ответы и объяснения 1
1)
var
i, n , cnt1, cnt2 : integer;
begin
readln(n);
for i:= 1 to n do
begin
if (i mod 2 = 0) then cnt1:= cnt1 + i
else cnt2:= cnt2 + i;
end;
Writeln('Сумма чисел = ', cnt1 + cnt2);
Writeln('Сумма не четных чисел = ', cnt1);
Writeln('Сумма четных чисел = ', cnt2);
end.
2)
var
i, a, b : integer;
begin
readln(a, b);
for i:= a to b do
Write(i*i, ' ');
end.
- 16.08.2015 09:35
- thumb_up 18
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.