Вопрос по информатике:
Разведчики-математики для того, чтобы опознать своих, используют числовые пароли. Услышав число-пароль, разведчик должен возвести его в квадрат и сказать в ответ первую цифры дробной части полученного числа. Напишите программу, которая по полученному паролю (вещественному числу) вычисляет число-ответ. Пример: Введите пароль: 1.92 Ответ: 6 (потому что 1,922 = 3, 6 864…, первая цифра дробной части – 6)
- 17.05.2018 13:48
- Информатика
- remove_red_eye 6872
- thumb_up 28
Ответы и объяснения 1
\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\
#include
using namespace std;
int main() { setlocale(LC_ALL, "Russian");
float pass, temp;
int answ;
cout << "Введите пароль: ";
cin >> pass;
temp = pass*pass;
temp *= 10;
answ = (int)temp;
answ = answ % 10;
cout << "Ответ: " << answ << endl;
system("pause");
return 0;
}
\\\\\\\\\\\\\\\\\\\\\\\\\\\\\
Скриншот работы во вложении....
- 18.05.2018 15:20
- thumb_up 41
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.