Вопрос по информатике:
1) напишите программу, которая спрашивает целые числа а и b и выводит на экран количество чётных и нечётных чисел в диапазоне от а до b
2)напишите программу, которая спрашивает целое число n , целые числа а и b,и выводит на экран n случайных чисел от а до b
Трудности с пониманием предмета? Готовишься к экзаменам, ОГЭ или ЕГЭ?
Воспользуйся формой подбора репетитора и занимайся онлайн. Пробный урок - бесплатно!
- 13.05.2016 06:43
- Информатика
- remove_red_eye 8743
- thumb_up 43
Ответы и объяснения 1
// Внимание! Если программа не работает, обновите версию!
1)
begin
var (a,b):=ReadInteger2('Введите границы диапазона:');
var Всего:=b-a+1; // количество целых чисел в диапазоне
var Четных,Нечетных:integer;
if a.IsOdd then begin Четных:=Всего div 2; Нечетных:=Всего-Четных end
else begin Нечетных:=Всего div 2; Четных:=Всего-Нечетных end; // четное a
Writeln('Нечетных- ',Нечетных,', четных- ',Четных)
end.
Пример
Введите границы диапазона: -4 4
Нечетных- 4, четных- 5
2)
begin
var (n,a,b):=ReadInteger3('Введите n,a,b:');
SeqRandom(n,a,b).Println
end.
Пример
Введите n,a,b: 15 -10 35
19 33 -10 4 5 -10 10 21 17 21 14 21 24 23 18
- 14.05.2016 09:13
- thumb_up 36
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.