Вопрос по информатике:
Требовалось написать программу, которая вводит с клавиатуры координаты точки на плоскости (x, y – действительные числа) и определяет принадлежность точки заштрихованной области, включая ее границы. Программист торопился и написал программу неправильно.
Вот она:
var x,y: real;
begin
readln(x,y);
if y<=3-x*x then
if y>=0 then
if y>=x+1 then
write('принадлежит')
else
write('не принадлежит')
end.
Последовательно выполните следующее:
1) приведите пример таких чисел x, y, при которых программа неверно решает поставленную задачу;
2) укажите, как нужно доработать программу, чтобы не было случаев ее неправильной работы; это можно сделать несколькими способами, поэтому можно указать любой способ доработки исходной программы.
- 04.01.2018 06:26
- Информатика
- remove_red_eye 12988
- thumb_up 26
Ответы и объяснения 1
var x,y: real;
begin
readln(x,y);
if y<=3-x*x then
if y>=0 and x>=0 or y>=x+1 and x < 0 then
write('принадлежит')
else
write('не принадлежит')
end.
- 05.01.2018 11:52
- thumb_up 39
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.