Вопрос по информатике:
Написать программу, которая вычисляет сумму первых n целых положительных целых чисел. Количество суммируемых чисел должно вводиться во время работы программы. Ниже представлен рекомендуемый вид экрана во время работы программы (данные, введенные пользователем, выделены жирным шрифтом).
Вычисление суммы положительных чисел.
Введите количество суммируемых чисел —> 20
Сумма первых 20 положительных чисел равна 210
- 02.02.2018 10:44
- Информатика
- remove_red_eye 9881
- thumb_up 48
Ответы и объяснения 1
program zad4;
uses crt;
var
s,i,n: integer;
begin
clrscr;
writeln('Вычисление суммы первых n положительных чисел');
writeln('введите количество суммируемых чисел');
readln(n);
s:=0;
for i:=1 to n do
begin
If n mod i =0 then
s:=s+n;
end;
writeln('сумма первых ',n,' положительных чисел равна ',s);
readln;
end.
Попробуй как-то так
- 03.02.2018 13:04
- thumb_up 33
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.