Вопрос по информатике:
Написать программу в C++ Найти все простые числа в заданном пользователем диапазоне [a; b].
- 06.01.2018 19:30
- Информатика
- remove_red_eye 3546
- thumb_up 10
Ответы и объяснения 1
#include
using namespace std;
bool prost(int m){
int k = 0;
for (int i=2; i<=sqrt(m); i++)
if (m % i == 0) k++;
return k==0;
}
int main(){
int a, b;
cin >> a >> b;
for (int i=a; i<=b; i++)
if (prost(i)) cout << i << " ";
return 0;
}
Пример:
5 20
5 7 11 13 17 19
- 07.01.2018 13:30
- thumb_up 14
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.