Вопрос по информатике:
Написать программу о нахождении двухзначного числа А.Найти сумму и произведение цифр данного числа,а также вывести новое число,в котором цифры числа А поменялись местами
- 08.12.2017 05:26
- Информатика
- remove_red_eye 11119
- thumb_up 26
Ответы и объяснения 1
begin
readln(a);
a1:=a div 10;
a2:=a mod 10;
writeln("Сумма цифр = ",a1+a2);
writeln("Произведение цифр = ",a1*a2);
writeln("Число наоборот: ",a2*10+a1);
end.
Пример:
25
Сумма цифр = 7
Произведение цифр = 10
Число наоборот: 52
- 09.12.2017 16:40
- thumb_up 32
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.