Вопрос по информатике:
На столе стоят три вазы с конфетами.В левой вазе лежат A конфет,в средней вообще лежат B конфет,в правой вазе лежат C конфет.Лена съедает одну конфету из левой вазы,затем-одну конфету из средней вазы,затем из правой,средней вазы,затем из правой,средней,левой,средней,правой,средней и т.д.
Если Лена хочет взять конфету из какой-то вазы ,а конфет там нет,она расстраивается и идёт спать.Определите,сколько конфет съест Лена
Программа получает на вход три целых неотрицательных числа A,B,C-количество конфет в левой,средней ,правой ВАЗе.
- 09.02.2018 12:04
- Информатика
- remove_red_eye 15179
- thumb_up 27
Ответы и объяснения 1
begin
readln(a,b,c);
f:=true; n:=0;
while f do
begin
if f and (a>0)
then begin a:=a-1; n:=n+1; end else f:=false;
if f and (b>0)
then begin b:=b-1; n:=n+1; end else f:=false;
if f and (c>0)
then begin c:=c-1; n:=n+1; end else f:=false;
if f and (b>0)
then begin b:=b-1; n:=n+1; end else f:=false;
end;
writeln(n);
end.
Пример:
3 3 3
7
- 01.01.1970 00:00
- thumb_up 17
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.