Вопрос по информатике:
Помогите с Пасклем!
На вход программе подаются три целых числа a, b, c – длины сторон треугольника. Вывести значение площади данного треугольника. Гарантируется, что с введёнными длинами сторон треугольник существует. Можно использовать любой способ нахождения площади треугольника.
- 19.02.2017 04:26
- Информатика
- remove_red_eye 15736
- thumb_up 46
Ответы и объяснения 1
begin
readln(a,b,c);
p:=(a+b+c)/2;
s:=sqrt(p*(p-a)*(p-b)*(p-c));
writeln('s = ',s:5:2);
end.
Пример:
3 4 5
s = 6.00
- 20.02.2017 02:36
- thumb_up 28
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.