Вопрос по информатике:
Составить программу на языке Паскаль.
а) Вычислить среднее арифметическое элементов массива А(20) равных за данному числу а.
б) Вычислить произведение модулей элементов массива А(20).
- 02.05.2018 07:51
- Информатика
- remove_red_eye 17552
- thumb_up 24
Ответы и объяснения 1
var
i, c, sum: shortint;
sr: real;
m: array[1..20] of shortint;
begin
sum := 0;
readln(c);
for i := 1 to c do
begin
readln(m[i]);
sum := sum + m[i];
end;
sr := sum / c;
sr := round(sr * 100) / 100; //если округлять не нужно, удали эту строчку
writeln('Среднее арифметическое: ', sr);
end.
Вторая задача:
var
i, c: shortint;
p: integer;
m: array[1..20] of shortint;
begin
p := 1;
readln(c);
for i := 1 to c do readln(m[i]);
for i := 1 to c do p := abs(p * (m[i]));
writeln('Произведение всех модулей массива: ', p)
end.
- 03.05.2018 16:55
- thumb_up 44
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.