Вопрос по информатике:
Выяснить, упорядочены ли цифры в записи числа по убыванию.
Написать программу в PascalABC.NET и нарисовать блок-схему.
- 25.04.2018 13:54
- Информатика
- remove_red_eye 771
- thumb_up 25
Ответы и объяснения 2
n: integer;
a, b: byte;
begin
read(n);
b := n mod 10;
n := n div 10;
a := n mod 10;
n := n div 10;
while (a > b) and (n 0) do
begin
b := a;
a := n mod 10;
n := n div 10;
end;
if a > b then
writeln('Цифры числа расположены по убыванию')
else
writeln('Цифры числа расположены не по убыванию')
end.
- 26.04.2018 16:38
- thumb_up 42
if (a mod 10) > max then beginmax:=(a mod 10);endelse k+=1;
a:=a div 10;if a max then beginmax:=(a mod 10);endelse k+=1;a:=1;
end;end;if k=0 then writeln('Убывание') else writeln('Неубывание');end.
- 27.04.2018 00:34
- thumb_up 7
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.