Вопрос по информатике:
Составьте программу вывода на экран всех простых чисел, не превосходящих заданного N. Простым называется натуральное число больше единицы, имеющее только два делителя: единицу и само это число.
- 05.09.2018 01:05
- Информатика
- remove_red_eye 14850
- thumb_up 45
Ответы и объяснения 2
#include
#include using namespace std;bool Has(const vector &primeNumbers, int value)
{
bool has = false;
for (int prime_number : primeNumbers)
{
if (value % prime_number == 0)
{
has = true;
}
}
return has;
}vector GetPrimeNumbers(int i)
{
vector primeNumbers= { 2, 3 };
for (int j = 4;j < i;j++)
{
if (!Has(primeNumbers, j))
{
primeNumbers.push_back(j);
}
}
return primeNumbers;
}int main()
{
int n;
cin >> n;
vector prime_numbers = GetPrimeNumbers(n);
for (int prime_number : prime_numbers)
{
cout << prime_number << endl;
}
cin >> n;
return 0;
}
- 06.09.2018 15:18
- thumb_up 25
1) Все же С++ изучают реже, чем Паскаль
2) Чтобы в очередной раз показать преимущества Паскаля над С-подобными языками для школьных задач.
Как говорится, "Имеющий глаза - да увидит!"
// PascalABC.NET 3.3, сборка 1555 от 21.10.2017
// Внимание! Если программа не работает, обновите версию!
begin
var n:=ReadInteger('N=');
for var i:=1 to n do begin
var (flag,j,r):=(True,2,Round(Sqrt(i)));
while flag and (j<=r) do
if i mod j = 0 then flag:=false
else j+=1;
if flag then Print(i)
end
end.
Пример
N= 150
1 2 3 5 7 11 13 17 19 23 29 31 37 41 43 47 53 59 61 67 71 73 79 83 89 97 101 103 107 109 113 127 131 137 139 149
- 07.09.2018 00:39
- thumb_up 33
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.