Вопрос по информатике:
Программа на с++
Дан массив, состоящий из целых чисел. Напишите программу, которая подсчитает количество элементов массива, больших предыдущего (элемента с предыдущим номером).
Входные данные
Сначала задано число N — количество элементов в массиве (1N10000). Далее через пробел записаны N чисел — элементы массива. Массив состоит из целых чисел.
Выходные данные
Необходимо вывести единственное число - количество элементов массива, больших предыдущего.
Примеры
входные данные
5
1 2 3 4 5
выходные данные
4
- 07.05.2018 07:58
- Информатика
- remove_red_eye 7458
- thumb_up 38
Ответы и объяснения 1
using namespace std;
int main() {
int n;
cin >> n;
int *arr = new int[n];
for (int i = 0; i < n; i++) {
cin >> arr[i];
}
int counter=0;
for (int i = 1; i < n; i++) {
if (arr[i] > arr[i-1]) {
counter++;
}
}
cout << counter;
return 0;
}
- 08.05.2018 09:11
- thumb_up 6
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.