Вопрос по информатике:
Написать программу поиска минимального значения в массиве, вывести на экран минимальное значение и номер (индекс) этого значения.
- 04.11.2017 11:04
- Информатика
- remove_red_eye 19961
- thumb_up 7
Ответы и объяснения 1
// Внимание! Если программа не работает, обновите версию!
begin
var a:=ArrRandom(ReadInteger('n='),-99,99); a.Println;
var i:=a.IndexMin;
Writeln('Минимальный элемент ',a[i],' имеет индекс ',i+1)
end.
Пример
n= 15
66 -91 75 27 7 -95 96 48 -35 77 49 71 -13 25 -8
Минимальный элемент -95 имеет индекс 6
- 05.11.2017 22:04
- thumb_up 47
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.