Вопрос по информатике:
Составьте программу для нахождения наибольшего и наименьшего значения заданной функции на заданном интервале (В PASCAL)
- 05.05.2018 01:37
- Информатика
- remove_red_eye 2234
- thumb_up 20
Ответы и объяснения 1
begin
readln(a,b,h);
x:=a; y:=2*x*x-0.5*x+5;
min:=y; max:=y;
writeln(x:4:1,' ',y:6:2);
for i:=1 to round((b-a)/h) do
begin
x:=x+h;
y:=2*x*x-0.5*x+5;
writeln(x:4:1,' ',y:6:2);
if y
end;
writeln('min = ',min:6:2,' max = ',max:6:2);
end.
Пример:
-2 2 0.5
-2.0 14.00
-1.5 10.25
-1.0 7.50
-0.5 5.75
0.0 5.00
0.5 5.25
1.0 6.50
1.5 8.75
2.0 12.00
min = 5.00 max = 14.00
- 06.05.2018 20:11
- thumb_up 39
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.