Вопрос по информатике:
Написать программу, которая вводит с клавиатуры последовательность из 5-ти вещественных чисел и после ввода каждого числа выводит среднее арифметическое полученной части последовательности
На паскале (через for to do)
- 22.10.2017 05:00
- Информатика
- remove_red_eye 2200
- thumb_up 49
Ответы и объяснения 1
begin
s:=0;
for i:=1 to 5 do
begin
readln(a);
s:=s+a;
writeln(s/i:5:2);
end;
end.
Пример:
2.8
2.80
9.4
6.10
0.7
4.30
6.0
4.72
4.1
4.60
- 23.10.2017 06:17
- thumb_up 38
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.