Вопрос по информатике:
Составить программу которая заполняет массив а [1...10] случайными целыми числами в диапазоне от 1 до 10 и вычисляет сумму элементов массива с индексом от n до m включительно. Числа n и m введите с клавиатуры
- 25.07.2018 17:29
- Информатика
- remove_red_eye 17775
- thumb_up 43
Ответы и объяснения 1
// Внимание! Если программа не работает, обновите версию!
begin
var a:=ArrRandom(10,1,10); a.Println;
var (n,m):=ReadInteger2('Введите n и m:');
Writeln('S=',a[n-1:m].Sum)
end.
Пример
1 8 9 1 2 1 10 4 10 2
Введите n и m: 3 6
S=13
- 26.07.2018 02:39
- thumb_up 21
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.