Вопрос по информатике:
Висящие вешалки Мишу не устроили, и он решил создать арт-объект. Он повесил одну вешалку, а на ее перекладину - ещё две, получился арт-объект. Ему показалось мало, и он стал вешать на перекладину нижней вешалки ещё по две. В итоге у него получилось n этажей. Напишите программу, которая определит, сколько вешалок понадобилось ямище для создания арт-объекта. Входные данные: n<=100 Выходные данные: вывести одно число - количество необходимых вешалок. Пример: Вх.: 3, Вых.: 7
- 12.09.2016 06:56
- Информатика
- remove_red_eye 3453
- thumb_up 34
Ответы и объяснения 1
var n,i:integer; k:real;
begin
readln(n);
k:=1;
for i:=1 to n do k:=k*2;
writeln(k-1);
end.
Пример:
3
7
- 13.09.2016 20:32
- thumb_up 4
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.