Вопрос по информатике:
Решить задачи в PascalABCNET.
Срок сдачи
21 октября 2017 г
(Составьте программу, которая проверяет оканчиваются ли вводимые числа на 5. Составьте программу, которая проверяет: является ли вводимое число двузначным и равна ли сумма цифр числа 8.)
- 18.05.2018 07:56
- Информатика
- remove_red_eye 19839
- thumb_up 15
Ответы и объяснения 1
var x: integer;
begin
writeln('Введите число');
readln(x);
if (x mod 10 = 5) or (x mod 10 = -5) then
writeln('Число оканчивается на 5')
else
writeln('Число не оканчивается на 5');
end.
program p2;
var x, y, sum: integer;
begin
writeln('введите число');
readln(x);
if ((x >= 10) and (x <= 99)) or ((x = -99)) then
writeln('является двузначным')
else
writeln('не является двузначным');
y := abs(x);
sum := 0;
while (y 0) do
begin;
sum := sum + (y mod 10);
y := y div 10;
end;
if sum = 8 then
writeln('сумма цифр равна 8')
else
writeln('сумма цифр не равна 8');
end.
- 19.05.2018 06:07
- thumb_up 32
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.