Вопрос по информатике:
Спектакль начинается в а часов b минут и заканчивается в c часов d минут (в те же сутки). Определите продолжительность спектакля.
Входные данные
Вводятся четыре целых не отрицательных числа a , b , c , d , разделенные пробелом. a и c не превосходят 23, b и d не превосходят 59. Гарантируется, что либо a < c , либо ( a = c и b < d ).
Выходные данные
Выведите через пробел два числа — часы и минуты. Второе число не должно превосходить 59.СДЕЛДАТЬ НА PASCAL ABC
- 03.08.2018 13:54
- Информатика
- remove_red_eye 14759
- thumb_up 13
Ответы и объяснения 1
begin
readln(a,b,c,d);
h:=(c*60+d-a*60-b) div 60;
m:=(c*60+d-a*60-b) mod 60;
writeln(h,' ',m);
end.
Пример:
18 30 21 15
2 45
- 04.08.2018 21:54
- thumb_up 37
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.