Вопрос по информатике:
Входной замок Лисы Алисы работает следующим образом: если введено натуральное число, которое меньше 100 или больше 999-на дисплее устройства появляется надпись False если у введённого числа сумма цифр равна 13-появляется Enter и можно войти; в остальных случаях появляется надпись LOCK
Входные данные: натуральное число N (1 больше N меньше 10000
Выходные данные: необходимо вывести надпись которая должна быть на дисплее
Пример
Ввод 2 Вывод FALSE
Ввод 427 Вывод ENTER
Ввод 318 Вывод LOCK
- 19.04.2018 13:14
- Информатика
- remove_red_eye 8757
- thumb_up 44
Ответы и объяснения 1
begin
readln(n);
case n of
100..999:
begin
s:=(n div 100)+(n div 10 mod 10)+(n mod 10);
if s=13 then writeln('ENTER') else writeln('LOCK');
end
else writeln('FALSE');
end;
end.
Пример:
427
ENTER
- 20.04.2018 22:04
- thumb_up 28
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.