Вопрос по информатике:
Вася и юра придумали новый язык. Слова в нем образуются от слов обычного русского языка, но после каждой гласной они ставят букву "C" и эту же гласную. Например слово "числитель" на их языке будет звучать "чисислиситесель". Напишите программу которая бы записсывала строку, состоящую из слов нормального русского языка, на новом, придуманном Васей и Юрой языке. (Входные данные, S-- письмо не более 255 символов)++(Выходные данные st--преобразованная строка)
- 12.03.2018 22:06
- Информатика
- remove_red_eye 9820
- thumb_up 37
Ответы и объяснения 1
// Внимание! Если программа не работает, обновите версию!
begin
var Гласные:=['а','е','ё','и','о','у','ы','э','ю','я'];
var s:=ReadlnString;
for var i:=s.Length downto 1 do
if LowCase(s[i]) in Гласные then Insert('c'+LowCase(s[i]),s,i+1);
Writeln(s)
end.
Примеры
Числитель
Чиcислиcитеcель
Анастасия, принеси бумагу и силикатный клей!
Аcанаcастаcасиcияcя, приcинеcесиcи буcумаcагуcу иcи сиcилиcикаcатныcый клеcей!
- 13.03.2018 02:26
- thumb_up 29
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.