Вопрос по информатике:
ПОЖАЛУЙСТА ПОМОГИТЕ РЕШИТЬ ЭТУ ЗАДАЧУ . (Написать программу на языке C++) . В некотором государстве в обращении применяются купюры достоинством 1, 5, 10, 50, 100, 500 и 1000 единиц. Сколькими способами можно разменять купюру достоинством 1000 единиц? Найти количество всех простых чисел в диапазоне от 2 до 100 000.
- 09.07.2018 23:55
- Информатика
- remove_red_eye 16206
- thumb_up 5
Ответы и объяснения 1
#include
#include
using namespace std;
int main()
{
unsigned a = 0, b = 0;
cin >> a >> b;
vector v(b + 1, '1');
for (unsigned i = 3; i < v.size(); i += 2) {
for (unsigned j = i + i; j < v.size(); j += i) {
vec[j] = '0';
}
}
if (a == 2) {
cout << 2 << " ";
}
a += !(a&1);
for (unsigned i = a; i < v.size(); i+=2){
if (vec[i] == '1') {
cout << i << " ";
}
}
return 0;
}
- 01.01.1970 00:00
- thumb_up 17
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.