Вопрос по информатике:
Программа получает на вход количество чисел в последовательности, а затем сами числа. Количество чисел не превышает 100. Введённые числа не превышают 300. Программа должна вывести среднее арифметичесткое чисел, трёхзначных, или вывести "NO", если таких чисел нет. Значение выводить с точностью до сотых.
- 23.02.2018 09:25
- Информатика
- remove_red_eye 12673
- thumb_up 16
Ответы и объяснения 1
var
s, k : integer;
begin
var n := ReadlnInteger('Сколько будет чисел? ');
writeln('Вводите числа');
var a := ReadArrInteger(n);
for var i:=0 to n-1 do
if (a[i] > 99) and
(a[i] < 1000) then begin
s := s + a[i];
k += 1
end;
if k = 0 then
writeln('NO')
else
writeln('Среднее арифметическое равно ', (s / k):8:2)
end.
- 24.02.2018 18:45
- thumb_up 40
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.