Вопрос по информатике:
Помогите, пожалуйста решить задачу в Паскале!
Однажды первокласснику Вовочке задали задание сложить из спичек прямоугольник, и вычислить его площадь. С заданием Вовочка справился, однако заметил, что из одного и того же количества спичек можно сложить разные прямоугольники, а иногда, чтоб сложить прямоугольник, не удается использовать все спички. Например из 14 спичек можно сложить прямоугольники со сторонами 1 и 6, 2 и 5, 3 и 4. Естественно, Вовочке хочется сложить прямоугольник максимальной площади, но это для него слишком сложная задача. Напишите программу, которая по данному количеству спичек определит, какой максимальной площади можно составить прямоугольник из этих спичек (спички ломать не разрешается)
- 18.04.2016 18:55
- Информатика
- remove_red_eye 8893
- thumb_up 12
Ответы и объяснения 2
begin
max:=0;
write('Количество спичек: ');
readln(n);
for a:=1 to n div 2 do
begin
for b:=a to n div 2 do
begin
if (a*b>max)and ((2*a)+(2*b)<=n) then
max:=a*b;
end;
end;
write('Максимальная площадь: ',max);
end.
- 19.04.2016 01:08
- thumb_up 42
// Внимание! Если программа не работает, обновите версию!
begin
var n:=ReadInteger('Количество спичек:');
var (n2,n4):=(n div 2, n div 4);
Writeln('Максимальная площадь: ',n2=2*n4?n4*n4:n4*(n4+1))
end.
Пример
Количество спичек:1 4
Максимальная площадь: 12
- 20.04.2016 00:02
- thumb_up 20
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.