Вопрос по информатике:
По данным двум натуральным числам A и B (A≤B) выведите все чётные числа на отрезке от A до B. В этой задаче нельзя использовать инструкцию if.
Входные данныеВводятся два натуральных числа A и B.
Выходные данныеВыведите ответ на задачу.
Примерывходные данные1 10 выходные данные2 4 6 8 10решение для питона
- 05.07.2018 18:26
- Информатика
- remove_red_eye 6089
- thumb_up 27
Ответы и объяснения 1
#include
using namespace std;
int main()
{
int a, b;
cin >> a >> b;
for (int i = a + (a % 2); i <= b; i += 2) {
cout << i << " ";
}
return 0;
}
- 06.07.2018 21:59
- thumb_up 25
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.