Вопрос по информатике:
Помогите Паскаль составить программу
Отсортировать 4 столбец двумерного массива по возрастанию (8 на 8)
- 26.11.2015 00:58
- Информатика
- remove_red_eye 6392
- thumb_up 10
Ответы и объяснения 1
// Внимание! Если программа не работает, обновите версию!
begin
Writeln('*** Исходный массив ***');
var a:=MatrRandom(8,8,-99,99);
a.Println(4); Writeln(4*a.ColCount*'-');
a.SetCol(3,a.Col(3).OrderBy(x->x).ToArray);
Writeln('*** Полученный массив ***'); a.Println(4)
end.
Пример
*** Исходный массив ***
77 68 79 -85 30 -28 -11 85
-52 -62 -94 -30 -82 31 -16 -80
-97 -95 84 -62 -53 5 68 -23
53 7 38 10 -88 -66 98 85
-99 -31 -6 71 32 -2 84 -87
45 46 -35 -2 -97 -46 -76 -66
-18 -10 72 -95 73 -55 -7 -27
99 3 -39 -77 33 78 73 -85
--------------------------------
*** Полученный массив ***
77 68 79 -95 30 -28 -11 85
-52 -62 -94 -85 -82 31 -16 -80
-97 -95 84 -77 -53 5 68 -23
53 7 38 -62 -88 -66 98 85
-99 -31 -6 -30 32 -2 84 -87
45 46 -35 -2 -97 -46 -76 -66
-18 -10 72 10 73 -55 -7 -27
99 3 -39 71 33 78 73 -85
- 26.11.2015 12:23
- thumb_up 31
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.