Вопрос по информатике:
Программа на с++
Напишите программу, которая вводит натуральные числа a и b , и выводит сумму квадратов натуральных чисел в диапазоне от a до b .
Входные данные
Входная строк содержит два натуральных числа – границы диапазона a и b . Гарантируется, что a ≤ b .
Выходные данные
Программа должна вывести одно число – сумму квадратов натуральных чисел из диапазона [ a , b ] .
Трудности с пониманием предмета? Готовишься к экзаменам, ОГЭ или ЕГЭ?
Воспользуйся формой подбора репетитора и занимайся онлайн. Пробный урок - бесплатно!
- 04.06.2015 03:40
- Информатика
- remove_red_eye 5827
- thumb_up 18
Ответы и объяснения 2
#include
using namespace std;
int main()
{
int a, b, sum = 0;
cin >> a >> b;
for (int i = a; i <= b; ++i) {
sum += pow(i, 2);
}
cout << sum << endl;
return 0;
}
- 06.06.2015 16:59
- thumb_up 25
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.