Вопрос по информатике:
СРОЧНО!!!
Число Цукамерна - натуральное число, которое делится на произведение своих цифр, например 175 делится на 1*7*5=35. Составить программу, которая выводит на экран все трёхзначные числа Цукамерна.
Пожалуйста помогите!!!
- 02.05.2017 00:09
- Информатика
- remove_red_eye 7285
- thumb_up 11
Ответы и объяснения 1
begin
readln(k);
a:=k div 100;
b:=k div 10 mod 10;
c:=c mod 10;
l:=a*b*c;
if (k mod l=0) then writeln(k);
end.
- 02.05.2017 13:41
- thumb_up 20
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.