Вопрос по информатике:
В магазине акция:скидка 5% на товары,цена которых превышает 1000руб.Напишите программу(в питоне),отчасти имитирующую работу кассы:вводятся цены покупаемых товаров,нужно вывести общую стоимость товаров с учетом скидки.
Форма ввода:несколько действительных чисел-цены на товары. Каждое число записано в отдельной строке. Последнее число-отрицаиельное-сигнал остановки.
формат вывода:одно действительное число- общая стоимость с учетом скидки. Помогите, пожалуйста, направьте хотя бы как while и if совместить или что вообще надо?
- 22.10.2017 07:55
- Информатика
- remove_red_eye 16503
- thumb_up 33
Ответы и объяснения 1
var
a:integer;
b:real;
begin
writeln('введите сумму покупки');
readln(a);
b:=a;
if a>500 then b:=a/1.03;
if a>1000 then b:=a/1.05;
writeln('сумма покупки с учетом скидки равна:',b);
readln;
end.
- 23.10.2017 02:07
- thumb_up 21
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.