Вопрос по информатике:
Написать программу в С++, которая проверяла бы:"Число армстронга или нет".
Если что, число армстронга-это число в котором сумма цифр=самому числу. Причем каждая цифра в таком степени, сколько цифр в самом числе, например число 153-армстронга, потому что 153=1³+5³+3³. Если можно,напишите программу так, чтоб я, как новичок понял, плииииз))))). РЕШИТЬ ЧЕРЕЗ ФУНКЦИИ.
- 11.01.2018 22:27
- Информатика
- remove_red_eye 8128
- thumb_up 49
Ответы и объяснения 1
#include
using namespace std;
void isArmstrong(const int number)
{
int origNum, num, rem, sum = 0;
origNum = number;
num = origNum;
while(num != 0) {
rem = num % 10;
sum += pow(rem, 3);
num /= 10;
}
if(sum == origNum)
cout << origNum << " is an Armstrong number.";
else
cout << origNum << " is not an Armstrong number.";
}
int main()
{
isArmstrong(153);
return 0;
}
_________________________
С проверкой https://ideone.com/keY6PS
- 13.01.2018 00:19
- thumb_up 46
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.