Вопрос по информатике:
Написать программу в паскале, определяющую является ли число перевертышем в паскаль. p.s перевертыш т.е с двух сторон читается одинаково, например 111
помогите!!!!
- 27.01.2017 15:56
- Информатика
- remove_red_eye 10305
- thumb_up 31
Ответы и объяснения 1
// Внимание! Если программа не работает, обновите версию!
begin
var n:=ReadInteger('Введите натуральное число: ').ToString;
if n=ReverseString(n) then Writeln('Перевертыш')
else Writeln('не перевертыш')
end.
Пример
Введите натуральное число: 3527253
Перевертыш
Введите натуральное число: 135233
не перевертыш
- 28.01.2017 08:27
- thumb_up 19
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.