Вопрос по информатике:
C++. Напишите программу, которая вводит номер месяца и выводит название времени года на английском языке. При вводе неверного номера месяца должно быть выведено слово 'NO'.
- 20.09.2017 01:27
- Информатика
- remove_red_eye 7480
- thumb_up 24
Ответы и объяснения 2
using namespace std;
int main()
{
cout << "Enter month num: " << endl;
unsigned month = 0;
cin >> month;
if (month = 1) {
switch (month / 3) {
case 1:
cout << "Spring" << endl;
break;
case 2:
cout << "Summer" << endl;
break;
case 3:
cout << "Autumn" << endl;
break;
default:
cout << "Winter" << endl;
break;
}
} else {
cout << "NO" << endl;
}
return 0;
}
- 22.09.2017 00:21
- thumb_up 27
using namespace std;
int main(){
int x;
cin >> x;
if(x <= 0)
cout << "NO"
else if(x < 3)
cout << "Winter";
else if(x > 2 and x < 6)
cout << "Spring";
else if(x > 5 and x < 9)
cout << "Summer";
else if(x > 8 and x < 12)
cout << "Autumn";
else
cout << "NO;
return 0;
}
- 22.09.2017 05:18
- thumb_up 5
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.