Вопрос по информатике:
Выберите один правильный вариант ответа. В задание на сопоставление необходимо указать номер и букву (например, 1а).
1. Алгоритм – это…
a. Команды для компьютера
b. Неправильно заданный логарифм
c. Список приказов
d. Последовательность каких-либо действий
e. Набор команд, приводящих к достижению поставленной цели
2. Какой из документов является алгоритмом?
a. Правила техники безопасности
b. Рецепт приготовления торта
c. Список книг в библиотеке
d. Расписание движения поездов
e. Режим дня школьника
3. Детализация алгоритма предполагает:
a. Доведение действий до завершения
b. Получение ожидаемого ответа
c. Разбиение действий на более мелкие
d. Детальное рассмотрение условия задачи
e. Подробную постановку задачи
4. Алгоритмизация – это:
a. Разбор постановки задачи
b. Тема в курсе информатики
c. Процесс составления алгоритма
d. Ввод текста программы
e. Оптимизация заданного алгоритма
5. Блок-схема позволяет:
a. Получить ответ
b. Разбить задачу на блоки
c. Определить вид алгоритма
d. Описать исходные данные
e. Наглядно изобразить последовательность шагов
6. Программа вычисления площади и периметра квадрата является:
a. Циклическим алгоритмом
b. Линейным алгоритмом
c. Это вообще не алгоритм
d. Ветвящимся алгоритмом
e. Комбинированным алгоритмом
7. Дан оператор if a>5 then s:=s+1 else m:=m+2. Он является:
a. Комбинацией операций ветвления
b. Комбинацией операторов присваивания и ветвления
c. Условным оператором
d. Представлением условия
e. Блочной структурой условия
8. Найдите ошибочные записи в операторах:
a. В=А
b. S+2=4.25
c. R=A : B-1.78
d. If a then b:=0
e. A:=D:=C
f. If a=0 then b:=0
9. Сумма двух чисел в программе записывается как:
a. LET A+B
b. Sum A+B
c. S:=A+B
d. A+B:=S
e. LET S:=A+B
10. Системы программирования – это программы
a. прикладные
b. системные
c. инструментальные
d. тренажерные
e. игровые
11. Выберите выражение, в результате которого получено значение с=2, если а=14 и b=4
a. с := a mod b
b. с := b div a
c. с := a div b
d. с := b mod a
e. с := a/b
12. Переведите на язык программирования команды:
Ввести A,B
Увеличить А в 2 раза
Уменьшить В на 10
13. Объявите как массив:
Таблицу 5х5 из чисел
14. Отметьте правильный вариант записи операторов:
a. If a>b then c:=a-b else c:=a+b;
b. If a>b else c:=a-b then c:=a+b;
c. If a>b then c:=a+b; else c:=a-b;
d. If a>b then c=a-b else c=a+b;
15. Служебное слово Const в программе на языке Pascal фиксирует начало раздела программы, содержащего:
a. описание переменных;
b. описание меток;
c. описание констант;
d. описание сложных типов данных.
16. Служебное слово Type в программе на языке Pascal фиксирует начало раздела программы, содержащего:
a. описание переменных;
b. описание меток;
c. описание констант;
d. описание сложных типов данных.
17. Служебное слово Var в программе на языке Pascal фиксирует начало раздела программы, содержащего:
a. описание переменных;
b. описание меток;
c. описание констант;
d. описание сложных типов данных.
18. Определите результат выполнения алгоритма по блок-схеме (а=?).
a. 8
b. 16
c. 32
d. 12
19. Установите соответствие:
1. Присвоить a. write(a);
2. Начало b. read(a);
3. Описание c. var
4. Прочитать (ввести) d. begin
5. Вывести e. :=
20. Даны две стороны прямоугольника a и b. Найти его периметр P и площадь S: (P = 2*(a + b) , S=a2) Составить алгоритм на языке блок-схем и написать программу на языке Паскаль
- 09.04.2017 02:09
- Информатика
- remove_red_eye 9492
- thumb_up 41
Ответы и объяснения 1
2.b
3.c
4.c
5.e
6.b
7.c
8.c
9.c
10.с
11.a
12. Read(A,B); A:=A*2; B:+B+10;
13. var a: Array[1..5,1..5] of real;
14.a
15. c
16. d
17.a
18 нет блок схемы
19. 1-e 2-d 3-c 4-b 5-a
20. var a,b,S,P: real;
begin
write('Ввод сторон прямоугольника');
Read (a,b);
P:=(a+b)*2;
S:=a*b;
Write('Периметр:', P);
Write('Площадь:', S);
End.
Блок схему по программе легко нарисовать.
- 01.01.1970 00:00
- thumb_up 34
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.