Вопрос по информатике:
Напишите программу, которая в последовательности натуральных чисел находит среднее арифметическое чисел, кратных 8, или сообщает, что таких чисел нет (выводит «NO»). Программа получает на вход натуральные числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 – признак окончания ввода, не входит в последовательность).
Количество чисел не превышает 100. Введённые числа не превышают 300.
Программа должна вывести среднее арифметическое чисел, кратных 8, или вывести «NO», если таких чисел нет. Значение выводить с точностью до десятых.
НАПИСАТЬ ПРОГРАММУ ДЛЯ 9 КЛАССA, ИСПОЛЬЗУЯ ЦИКЛ WHILE
- 17.01.2018 04:18
- Информатика
- remove_red_eye 2667
- thumb_up 26
Ответы и объяснения 1
int k = 0;//кол-во чисел
int sum = 0;//сумма чисел
float sr;//среднее арифм
int a;//вводимые числа
do {
cout << "Enter: ";
cin >> a;
if (a != 0 && a % 8 == 0) {
++k;
sum += a;
}
} while (a != 0);
if (k != 0) {
sr = sum / static_cast(k);
}
if (k >= 1) {
cout << "Srednee arifm: " << sr << endl;
}
else {
cout << "NO" << endl;
}
- 18.01.2018 06:22
- thumb_up 31
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.