Вопрос по информатике:
Прошу решите на PascalABC или Phyton
Дано натуральное число. Требуется разделить запятыми тройки его цифр(считая справа).
Входные данные содержат натуральное число, не превосходящее 10 в 100
Выходные данные. То же число, разделяя тройки цифр запятыми.
Примеры:
Входные Выходные
1000 1,000
12345 12,345
- 10.06.2018 00:17
- Информатика
- remove_red_eye 6992
- thumb_up 18
Ответы и объяснения 1
s: string;
begin
write('Введите строку символов ');
readln(s);
n:=Length(s);
for var i:= 1 to ((n-1) div 3) do
insert(',',s,n-3*i+1);
writeln(s);
end.
-----------
АБС паскаль.
типа данных для 100 цифр числа нет, поэтому вводим в строковый тип, и поэтому всё равно, что бить по три, цифры или буквы.
- 11.06.2018 12:34
- thumb_up 48
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.