Вопрос по информатике:
Дан массив из 13 элементов. Элементами массива являются первые 13 нечетных чисел. Найти произведение элементов этого массива.
Написать программу в Паскале, как можно проще, без лишних наворотов, пожалуйста.
- 12.08.2018 00:33
- Информатика
- remove_red_eye 17404
- thumb_up 44
Ответы и объяснения 1
a: array [1..13] of integer;
begin
// заполняем массив
for var i:=1 to 13 do
a[i]:=i+i-1;
proizv:=1;
// основной цикл
for var i:=1 to 13 do
proizv:=proizv*a[i];
writeln('Произведение = ',proizv);
end.
-------------------------------
Это работает в АБС-паскале
Типа данных integer мало для хранения произведения, но int64 - достаточно
- 13.08.2018 01:25
- thumb_up 46
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.