Вопрос по информатике:
Язык c++.Задано натуральное число N. Напишите программу, которая определяет количество натуральных чисел, не больше N и не делятся ни на одно из чисел 2, 3, 5.
Входные данные: число N (1 ≤ N ≤ 1000000000).
Выходные данные: найденное число
пример
Input Output
10 2
Обратите внимание на то что программа проверяется компилятором ,и он не должен показывать ошибки.
- 24.06.2018 18:41
- Информатика
- remove_red_eye 15337
- thumb_up 18
Ответы и объяснения 1
using namespace std;
int main()
{
int n;
int k=0;
cout <> n, cout << "\n";
for (int i=1; i<=n; i++) {
if ((i%2 != 0)&&(i%3 != 0)&&(i%5 != 0)) k++;
}
cout << k << "\n";
return 0;
}
Пример:
n = 10
2
- 25.06.2018 00:46
- thumb_up 17
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.