Вопрос по информатике:
Задание 1. Напишите программу, которая вычисляет сумму целых чисел от а до 500 (значение a вводится с клавиатуры). Задание 2. Напишите программу, которая запрашивает два целых числа x и y, после чего вычисляет и выводит значение x в степени y. Задание 3. Найти среднее арифметическое всех целых чисел от 1 до 1000. Задание 4. Найти произведение всех целых чисел от a до 20 (значение a вводится с клавиатуры: 1 <=a <= 20). Задание 5. Написать программу, которая выводит на экран таблицу умножения на k, где k – номер варианта. Например, для 7-го варианта: 7 x 2 = 14 7 x 3 = 21
- 11.12.2017 20:35
- Информатика
- remove_red_eye 3924
- thumb_up 26
Ответы и объяснения 2
#include
using namespace std;
void main()
{
//задаём русский язык для консоли
setlocale(LC_ALL, "Russian");
long sum = 0;
int a;
cout << "Введите a" << endl;
cin >> a;
if (a > 500)
{
cout < 500" << endl;
}
else
{
sum = (500 * 501 / 2) - ((a - 1) * a ) / 2;
cout << sum;
}
}
2.
#include
using namespace std;
void main()
{
//задаём русский язык для консоли
setlocale(LC_ALL, "Russian");
double average = (1 + 1000) / 2.;
cout << "Среднее арифметические чисел от 1 до 1000" << average << endl;
}
3
#include
using namespace std;
void main()
{
//задаём русский язык для консоли
setlocale(LC_ALL, "Russian");
int a = 0, b = 0;
cout << "Введите границы диапазона" << endl;
cin >> a >> b;
cout << "Все числа:" << endl;
if (a <= b)
{
for (int i = a; i <= b; i++)
{
cout << i << endl;
}
}
else
{
for (int i = b; i < a; i++)
{
cout << i << endl;
}
}
cout << "Чётные числа:" << endl;
if (a <= b)
{
for (int i = a; i <= b; i++)
{
if (i % 2 == 0)
{
cout << i << endl;
}
}
}
else
{
for (int i = b; i < a; i++)
{
if (i % 2 == 0)
{
cout << i << endl;
}
}
}
cout << "Нечётные числа:" << endl;
if (a <= b)
{
for (int i = a; i <= b; i++)
{
if (i % 2 != 0)
{
cout << i << endl;
}
}
}
else
{
for (int i = b; i < a; i++)
{
if (i % 2 != 0)
{
cout << i << endl;
}
}
}
cout << "Числа, кратные 7:" << endl;
if (a <= b)
{
for (int i = a; i <= b; i++)
{
if (i % 7 == 0)
{
cout << i << endl;
}
}
}
else
{
for (int i = b; i < a; i++)
{
if (i % 7 == 0)
{
cout << i << endl;
}
}
}
}
4.
#include
using namespace std;
void main()
{
//задаём русский язык для консоли
setlocale(LC_ALL, "Russian");
int a = 0, sum = 0;
cout << "Введите числа" << endl;
while (true)
{
cin >> a;
if (a == 0)
{
break;
}
sum += a;
}
cout << "Сумма =" << sum << endl;
}
- 12.12.2017 04:32
- thumb_up 10
По поводу первой задачки есть куда более простое и короткое решение :)
#include <iostream>
using namespace std;
int main()
{
setlocale(LC_ALL, "Russian");
int i, sum = 0;
cout << "Введите число от 1 до 500: ";
cin >> i;
while (i <= 500)
{
sum += i;
i++;
}
cout << "Результат: " << sum;
return 0;
}
- 02.01.2022 17:40
- thumb_up 3
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.