Вопрос по информатике:
Язык C#. Написать программу на языке C#разветвляющейся структуры согласно вариантам задания 1 (используя if) и задания 2 (используя switch) .
1.Даны два числа. Большее из этих двух чисел заменить их полусуммой, а меньшее удвоенным произведением.
2.2. Вводится число экзаменов N<=20. Напечатать фразу "Мы успешно сдали N экзаменов", согласовав слово "экзамен" с числом N.
- 22.12.2017 18:42
- Информатика
- remove_red_eye 16626
- thumb_up 49
Ответы и объяснения 1
using System;
class Program
{
public static void Main()
{
double x,y,s,p;
Console.Write("x = ");
x = double.Parse(Console.ReadLine());
Console.Write("y = ");
y = double.Parse(Console.ReadLine());
s = (x+y)/2;
p = 2*x*y;
if (x>y){
x = p;
y = s;
}
else {
y = p;
x = s;
}
Console.WriteLine("x = {0}, y = {1}", x, y);
Console.ReadKey();
}
}
Пример:
x = 2.4
y = 8.3
x = 5.35, y = 39.84
2.
using System;
public class Test
{
public static void Main()
{
int n;
Console.Write("n = ");
n = int.Parse(Console.ReadLine());
switch (n){
case 1:
Console.WriteLine("Мы успешно сдали {0} экзамен", n);
break;
case 2:
case 3:
case 4:
Console.WriteLine("Мы успешно сдали {0} экзамена", n);
break;
default:
Console.WriteLine("Мы успешно сдали {0} экзаменов", n);
break;
}
}
}
Пример:
n = 6
Мы успешно сдали 6 экзаменов
- 23.12.2017 14:52
- thumb_up 18
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.