Вопрос по информатике:
Определите, является ли не более чем четырехзначное число k симметричным (например, 1331 или 0550). На вход программе подается целое число k (0 k 9999). Выдайте 1 при положительном ответе на вопрос задачи и любое другое целое число — в противном случае.
- 03.04.2018 01:50
- Информатика
- remove_red_eye 14320
- thumb_up 5
Ответы и объяснения 1
a:integer;
begin
readln(a);
If (a=0) then
If (a>999) then
If ((a div 1000)=(a mod 10)) and ((a div 10 mod 10)=(a div 100 mod 10)) then
writeln('1')
else
writeln('2')
else
If (a>99) and (a<1000) then
If ((a div 100)=(a mod 10)) then
writeln('1')
else
writeln('2')
else
If (a>9) and (a<100) then
If ((a div 10)=(a mod 10)) then
writeln('1')
else
writeln('2')
else
writeln('1')
else
writeln('Неправльное число');
end.
Большое немного решение, может можно и поменьше, но так точно правильно
- 04.04.2018 05:17
- thumb_up 49
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.