Вопрос по информатике:
Дан целочисленный массив из 10 элементов. Напишите программу, которая находит количество пар элементов массива, в которых хотя бы одно число делится на 3, под парой подразумевается два идущих подряд массива. Например : 6;2 ;9;-3;6. Ответ :4. работа в паскаль, помогите плиз
- 21.12.2017 03:34
- Информатика
- remove_red_eye 824
- thumb_up 23
Ответы и объяснения 1
program z1;
var a:array[10];
k,i:integer;
begin
k:=0;
readln(a);
for i:= 1 to 9 do
if (a[i] mod 3 =0) or (a[i+1] mod 3 = 0) then k:=k+1;
end;
writeln(k);
end.
- 22.12.2017 10:04
- thumb_up 23
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.