Вопрос по информатике:
Написать программу для pascal.
Программа считывает с клавиатуры массив из N элементов(N <1000) и выводит максимальный и минимальный элемент массива и их среднее арифметическое
Трудности с пониманием предмета? Готовишься к экзаменам, ОГЭ или ЕГЭ?
Воспользуйся формой подбора репетитора и занимайся онлайн. Пробный урок - бесплатно!
- 19.12.2015 14:52
- Информатика
- remove_red_eye 2673
- thumb_up 47
Ответы и объяснения 2
// Внимание! Если программа не работает, обновите версию!
begin
var a:=ReadArrReal('Вводите элементы массива'+NewLine,ReadInteger('n='));
Writeln('Max=',a.Max,', min=',a.Min,', среднее=',(a.Min+a.Max)/2)
end.
Пример
n= 8
Вводите элементы массива
3.45 -2.7 1.18 0 -2 4.623 -2.734 7
Max=7, min=-2.734, среднее=2.133
- 20.12.2015 17:11
- thumb_up 12
var x : array[1..1000] of integer;
n,i,max,min : integer;
begin
write('n = ');
readln(n);
writeln('Исходный массив:');
for i:=1 to n do begin
write('x[',i,']=');
readln(x[i]);
end;
writeln;
max:=x[1]; min:=x[1];
for i:=2 to n do
begin
if x[i] > max then max:=x[i];
if x[i] < min then min:=x[i];
end;
writeln('max=',max,' min=',min);
writeln('Среднее = ',(max+min)/2:5:2);
end.
Пример:
n = 5
Исходный массив:
x[1]=12
x[2]=45
x[3]=60
x[4]=72
x[5]=68
max=72 min=12
Среднее = 42.00
-----
2.
begin
var n:=ReadInteger('n = ');
var a:=ReadArrInteger('Вводите массив:',n);
Writeln('Max = ',a.Max);
Writeln('Min = ',a.Min);
Writeln('Среднее = ',(a.Max+a.Min)/2);
end.
- 21.12.2015 03:56
- thumb_up 47
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.