Вопрос по информатике:
Составьте программу, которая запрашивает три целых числа и, если ни одно из чисел не равно нулю, выводит на экран их среднее арифматическое.
- 21.07.2017 05:18
- Информатика
- remove_red_eye 3350
- thumb_up 9
Ответы и объяснения 2
var a, b, c: integer;
begin
write('Введите три целых числа: ');
readln(a, b, c)
if a0 and b0 and c0 then
writeln('Среднее арифметическое введенных чисел равно ', (a+b+c)/3:2:2)
else writeln('одно из чисел равно нулю, работа программы завершена');
end.
- 22.07.2017 07:16
- thumb_up 27
// Внимание! Если программа не работает, обновите версию!
begin
var (a,b,c):=ReadReal3('Введите через пробел три числа:');
if a*b*c0 then Writeln((a+b+c)/3)
end.
Пример
Введите через пробел три числа: 6.3 -12 8.143
0.814333333333333
- 23.07.2017 20:24
- thumb_up 10
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.