Вопрос по информатике:
Решето Эратосфена в PascalABC
Данные вводятся с клавиатуры или из файла input.txt, выводятся на экран или в файл output.txt. Первые тесты не всегда совпадают с примерами из условия.
Напишите программу, которая выводит все простые числа в диапазоне от 2 до N включительно ( 2 ≤ N ≤ 100000 ).
Входные данные
Входная строка содержит целое число N ( 2 ≤ N ≤ 100000 ).
Выходные данные
Программа должна вывести все простые числа в диапазоне от 2 до N в одну строку, разделив их пробелами.
Примеры
Входные данные : 20
Выходные данные : 2 3 5 7 11 13 17 19
- 09.01.2018 18:06
- Информатика
- remove_red_eye 17138
- thumb_up 26
Ответы и объяснения 1
var n,i: longint;
function simply(a: longint ):boolean;
var i: longint;
begin
simply:=true;
for i:=2 to trunc(sqrt(a)) do begin if a mod i=0 then begin
simply:=false;
break
end
end
end;
begin
readln(n);
for i:=2 to n do if simply(i) then write(i,' ');
end.
- 01.01.1970 00:00
- thumb_up 39
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.