Вопрос по информатике:
Помогите, пожалуйста, написать программу на языке паскаль " Напишите программу поиска максимального из четырех чисел с использованием подпрограммы поиска большего из двух. "
- 04.10.2017 08:04
- Информатика
- remove_red_eye 7754
- thumb_up 32
Ответы и объяснения 1
var a,b,c,d: integer;
function max(a,b: integer): integer;
begin
if a>b then max:=a else max:=b;
end;
begin
readln(a,b,c,d);
if max(a,b)> max(c,d) then write(max(a,b)) else write(max(c,d));
end.
- 05.10.2017 06:01
- thumb_up 21
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.