Вопрос по информатике:
С++ Напишите программу, которая вводит два вещественных числа (x и y) и вычисляет значение x^y.
- 24.01.2018 02:53
- Информатика
- remove_red_eye 9551
- thumb_up 18
Ответы и объяснения 2
int main()
{
float x, y;
float res = 1;
std::cin >> x >> y;
for (int i = 0; i < y; i++)
res *= x;
std::cout << res << std::endl;
}
- 26.01.2018 00:05
- thumb_up 4
{ (C) Puporev }
begin if x=0 then Power:=0
else
if x>0 then
Power:=exp(ln(x)*y)
else
Power:=-exp(ln(abs(x))*y);
end;
var x,y:real;
begin
readln(x,y);
writeln(power(x,y));
end.
- 26.01.2018 21:41
- thumb_up 44
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.