Вопрос по информатике:
Составить программу замены значений переменных a и b ( пусть дано : a=3 , b=5; требуется получить a=5, b=3)
Запись команд присваивания a:=b; b:=a; приведет к получению неверного результата: a=b=5 ( убедитесь в этом!).
- 15.10.2017 09:39
- Информатика
- remove_red_eye 19032
- thumb_up 49
Ответы и объяснения 1
var a,b,c:integer;
begin
readln(a,b);
c:=a;
a:=b;
b:=c;
writeln(a,' ',b);
end.
Пример:
3 5
5 3
- 16.10.2017 14:15
- thumb_up 33
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.