Вопрос по информатике:
Напишите программу в PascalABC: нахождение наибольшего целого делителя целого числа
- 19.09.2016 12:31
- Информатика
- remove_red_eye 9519
- thumb_up 48
Ответы и объяснения 1
found: boolean;
begin
d:=1;
found:=false;
writeln('Введите целое число больше единицы');
readln(n);
if n mod 2 = 0 then d := n div 2
else
begin
i:=(n div 2)-1;
while (found=false) and (i > 2) do
begin
if n mod i = 0 then begin found:=true; d:=i; end;
i:=i-1;
end;
end;
if d=1 then writeln('введённое число оказалось простым')
else writeln('наибольший целый делитель введённого числа равен ',d);
end.
- 20.09.2016 16:22
- thumb_up 39
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.