Вопрос по информатике:
Выясните лучший результат в соревнованиях по плаванию для N спортсменов и фамилию этого спортсмена.
Написать программу в Pascal ABC. Прошу помощи, хотя бы идею
- 05.12.2017 21:18
- Информатика
- remove_red_eye 11321
- thumb_up 45
Ответы и объяснения 1
// PascalABC.NET 3.3, сборка 1531 от 30.08.2017
// Внимание! Если программа не работает, обновите версию!
begin
var L:=new List;
// это не решение задачи, это ввод данных
Writeln('Введите в каждой строке фамилию, пробел, время');
var i:=1;
repeat
var s:=ReadlnString(i+': ');
if s[1]='*' then break;
var w:=s.ToWords;
L.Add(Rec(w[0],real.Parse(w[1])));
i+=1;
until false;
// а теперь само решение
Writeln(L.MinBy(x->x[1]))
end.
Пример
Введите в каждой строке фамилию, пробел, время
1: Иванов 10.3
2: Петров 9.9
3: Уточкин 10.1
4: *
(Петров,9.9)
- 06.12.2017 19:57
- thumb_up 47
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.